[Community] Help installing ZCO/PrimaGIS

Matthew Perry perrygeo at gmail.com
Sun Jan 15 21:54:30 EET 2006


Sean, Anders,

 Thanks for the tips. I finally made some progress but am still a long
way from having a functional installation...

Taking Anders advice, I tried testing PCL and something was amiss.
When I tried the example given at
http://zmapserver.sourceforge.net/PCL/, I got errors due to the lack
of ogr module in python 2.3.  I wasn't aware that the python binding
for ogr were required by PCL. I installed them from source for my
python2.3 (the Ubunutu package only has version 2.4 python-gdal
bindings. Of course then comes reinstalling mapserver, & mapscript.
Now PCL works fine.. I think.

At that point, the ZCO and PrimaGIS were loaded by Zope. But adding a
ZCO Data store would produce errors. The event.log file contained some
clues ;-) (thanks Sean) I needed the lxml module for python2.3.

I then tried to follow along with the HOWTO for adding a PrimaGIS
layer  (http://www.primagis.fi/documentation/examples/add_primagislayer).
The data store was added successfully but when I go to the "edit" tab
on the ZCOLayer, the overview image was broken. Opening the image url
in a seperate window, I got the following error:

Site Error
An error was encountered while publishing this resource.
Error Type: AttributeError
Error Value: mapper

event.log shows me:

Traceback (most recent call last):
  File "/usr/lib/zope2.8/lib/python/ZPublisher/Publish.py", line 113, in publish
    request, bind=1)
  File "/usr/lib/zope2.8/lib/python/ZPublisher/mapply.py", line 88, in mapply
    if debug is not None: return debug(object,args,context)
  File "/usr/lib/zope2.8/lib/python/ZPublisher/Publish.py", line 40,
in call_object
    result=apply(object,args) # Type s<cr> to step into published object.
  File "/var/lib/zope2.8/instance/plone-site/Products/ZCO/overview.py",
line 55, in overview
    m = self.mapper
AttributeError: mapper

My guess is that something is not right with my installation. There
are so many potential points of failure that I don't know where to
begin debugging. Has anyone run into this problem before?

matt

> Sean Gillies skrev:
> > Nothing about them in the logs? I'm stumped. You've extracted the
> > tarballs, yes? Zope should be executing code in instance/plone-site/
> > Products/ZCO/__init__.py and .../Products/PrimaGIS/__init__.py, and
> > errors should be output to the site event.log in the filesystem.
> >
> > If this isn't happening, something is very wrong.

On 1/11/06, Anders Avlesen <anders.avlesen at ntnu.no> wrote:
> I'm not sure if this helps, but for me the trick to install PrimaGIS
> successfully was to make sure that PCL is installed properly. To check
> this I ran
> query.py from the PCL examples manually in a python shell (You need to
> edit paths in query.py first). If this worked, everything else would
> also work. If it did not, ZCO would not
> be available through Zope.



--
Matt Perry
perrygeo at gmail.com
http://www.perrygeo.net



More information about the Community mailing list