[Community] Weird problem with Rtree on 64bits

Nabil Servais nabil.servais at gmail.com
Tue Jun 22 16:41:09 EEST 2010


  Hello everyone,

I use graphserver on a fedora 13 64 bits and when I try to import data 
I've got this strange error about Rtree:

$ gs_import_osm france.osm france.osmdb
Traceback (most recent call last):
   File "/usr/bin/gs_import_osm", line 9, in <module>
     load_entry_point('graphserver==0.1', 'console_scripts', 
'gs_import_osm')()
   File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 299, 
in load_entry_point
     return get_distribution(dist).load_entry_point(group, name)
   File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2229, 
in load_entry_point
     return ep.load()
   File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1948, 
in load
     entry = __import__(self.module_name, globals(),globals(), ['__name__'])
   File 
"/usr/lib/python2.6/site-packages/graphserver-0.1-py2.6.egg/graphserver/compiler/__init__.py", 
line 1, in <module>
     from tools import *
   File 
"/usr/lib/python2.6/site-packages/graphserver-0.1-py2.6.egg/graphserver/compiler/tools.py", 
line 3, in <module>
     from graphserver.ext.osm.osmdb import OSMDB
   File 
"/usr/lib/python2.6/site-packages/graphserver-0.1-py2.6.egg/graphserver/ext/osm/osmdb.py", 
line 12, in <module>
     from rtree import Rtree
   File 
"/usr/lib/python2.6/site-packages/Rtree-0.6.0-py2.6.egg/rtree/__init__.py", 
line 8, in <module>
     from index import Rtree
   File 
"/usr/lib/python2.6/site-packages/Rtree-0.6.0-py2.6.egg/rtree/index.py", 
line 2, in <module>
     import core
   File 
"/usr/lib/python2.6/site-packages/Rtree-0.6.0-py2.6.egg/rtree/core.py", 
line 85, in <module>
     rt = ctypes.CDLL(lib_name)
   File "/usr/lib64/python2.6/ctypes/__init__.py", line 353, in __init__
     self._handle = _dlopen(self._name, mode)
OSError: /usr/local/lib/libspatialindex_c.so: undefined symbol: 
_ZTVN10__cxxabiv121__vmi_class_type_infoE





More information about the Community mailing list